Articles of gem

Rmagick erros ao executar o Rails S após a atualização para o OSX Mavericks 10.9

Eu atualizei meu osx para Mavericks 10.9 de 10.7, e desde então eu tenho tido problemas rodando ‘rails s’. A questão é com o Rmagick, e eu tentei quase todas as soluções que pude encontrar. A maioria das pessoas recomendou a reinstalação do imagemagick através do homebrew e a reinstalação do rmagick gem, mas isso […]

Remover RVM, Ruby e gemas completamente?

Eu tive que rebaixar o Rails e agora as gemas, as versões, e tudo mais, estão completamente confusas e eu sinto vontade de pular da minha janela. Eu só quero destruir tudo relacionado com RVM, Ruby e gemas para ter certeza de fazer uma reinstalação 100% limpa. Como eu posso fazer isso?

Como posso aumentar um campo em uma gema de rails?

Estou recebendo este erro: SQL (31.1ms) INSERT INTO “read_marks” (“readable_id”, “readable_type”, “timestamp”, “user_id”) VALUES ($1, $2, $3, $4) RETURNING “id” [[“readable_id”, nil], [“readable_type”, “PublicActivity::ORM::ActiveRecord::Activity”], [“timestamp”, Mon, 04 Mar 2013 03:29:52 UTC +00:00], [“user_id”, 2]] PG::Error: ERROR: value too long for type character varying(20) Porque “readable_type” contém apenas 20 caracteres e eu estou passando em “PublicActivity […]

Aplicativo Rails com JRuby não está funcionando

Eu tenho um aplicativo Rails que foi criado no Ubuntu. Eu queria executá-lo em um Mac, mas depois de instalar pacotes e correndo rails s , recebo seguintes erros: LoadError: erro de carregamento: sqlite3 / sqlite3_native – java.lang.UnsatisfiedLinkError: falha ao carregar biblioteca de correção, erro: dlopen (/Users/home/.rvm/rubyes/jruby-1.7.4/lib/native/Darwin/libjruby- cext.dylib, 10): imagem não encontrada requer em org […]

Rails 4 postgres bug – não pode criar database porque a pg gem “está faltando”, mas não é

Eu uso borda de rails (4.0) e ao executar: bundle exec rake db:create eu recebo Specified ‘postgresql’ for database adapter, but the gem is not loaded. Add `gem ‘pg’` to your Gemfile. Eu tenho “gem pg” no meu Gemfile e tenho executado a instalação do pacote … qual poderia ser a razão disso? obrigado

Rails 3.1.1 implantar para Heroku falhando

Depois de atualizar meu aplicativo Rails 3.0.9 para 3.1.1, estou recebendo o seguinte erro bundler ao enviar para a pilha Heroku-cedar: —–> Heroku receiving push —–> Ruby/Rails app detected —–> Installing dependencies using Bundler version 1.1.rc Running: bundle install –without development:test –path vendor/bundle Updating git://github.com/sferik/rails_admin.git Fetching gem metadata from http://rubygems.org/…….. Bundler could not find compatible […]

Ruby on Rails: Não é possível instalar a gem JSON

Quando tento criar um novo aplicativo Rails Rails, o processo pára ao tentar instalar o gem JSON. Então, eu tentei instalar sozinho, usando: gem install json mas recebo a seguinte mensagem de erro: Building native extensions. This could take a while… ERROR: Error installing json: ERROR: Failed to build gem native extension. /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb creating […]

Como faço para colocar os slugs dos usuários na lista negra com ID amigável?

Quero usar o ID para que os usuários possam ter um bom URL. No entanto, quero colocar na lista negra alguns nomes, como api, admin ou palavrões. Onde eu carrego o arquivo yaml para fazer isso? no modelo?

Link ruby ​​para RVM

Tentei procurar uma resposta por cerca de uma hora, mas sem sorte. Eu instalei o ruby-2.0.0 com o meu rvm, mas o sistema detecta apenas o antigo ruby-1.9.3 Eu mudei o link sym em /usr/bin/ruby para apontar para o meu ruby ~/.rvm e agora eu recebo o seguindo quando eu corro ruby -v ruby 2.0.0p451 […]

Por que o heroku não lista as mesmas gemas que eu tenho localmente?

Eu ainda sou muito novo para heroku e git hub and rails. Meu aplicativo funciona localmente, mas falha no Heroku. As linhas de falha indicam que é porque falta o plugin que instalei localmente. Esta é uma questão básica que não consigo encontrar. Como posso garantir ou atualizar a lista de gemas no heroku para […]